关于“Yii2 高级模板”的使用

icy2003 程序 2020-03-15 23:54:26 267 1条

还在为无法正常安装 Yii2 烦恼么?来试试这个!

yii2.jpg

起因

- yiisoft/yii2 2.0.12 requires bower-asset/jquery 2.2.@stable | 2.1.@stable | 1.11.@stable | 1.12.@stable -> no matching package found.

我是 Yii2 的忠实粉丝,但是每次安装 Yii2 都会遇到上面的依赖问题!

网上的方法是说用 fxp/composer-asset-plugin 解决,但搜出来的关于这个包的文章有各种版本,而我很不幸地只成功过几次,于是我就好好读了一下这个报错,大概意思是,报错里提到的包都不存在,事实是,在 packagist 里搜索后的确是不存在的。

解决

偶然的机会我发现了 yidas/yii2-bower-asset,按照作者对这个包的解释,并且换上阿里云的 composer 源后,全程无障碍安装 Yii2。作者还提到了安装此包后无法使用 bower,刚好我对 bower 比较熟悉,实际上只要稍微改动一些配置就能使用 bower。

不过……我都把这些事情做了,也就是 Yii2 高级模板

最后

composer update 后的 Yii2 安装步骤在这里

我这个项目后续的更新都是个人项目内容,如果你只需要纯净版的 Yii2 高级模板,那就直接下载这个包就好了。

上一篇 没有了
下一篇 Yii2 数据库迁移组件的使用
标签: php, yii2

非特殊说明,本博所有文章均为博主原创。


唉呀 ~ 仅有一条评论


  1. Aeolus
    Aeolus 2020-03-20 15:18:52

    good